SQL-инъекция в MySQL

Дата публикации:
06.06.2006
Всего просмотров:
3553
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MySQL 4.x
MySQL 5.x
Уязвимые версии:
MySQL 4.1.19 и более ранние версии
MySQL 5.0.21 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды на системе.

Уязвимость существует из-за ошибки при обработке входных данных в функции "mysql_real_escape_string()". Удаленный пользователь может обойти защиту от SQL-инъекции в окружении, использующем мультибайтные символы, и выполнить произвольные SQL команды в базе данных. Уязвимость относится к:
SQL-инъекция в PostgreSQL

URL производителя: www.mysql.com

Решение: Установите последнюю версию (4.1.20 или 5.0.22) с сайта производителя.

или введите имя

CAPTCHA