PHP-инклюдинг в phpBB Activity Mod Plus

Дата публикации:
06.06.2006
Дата изменения:
17.10.2006
Всего просмотров:
1932
Опасность:
Высокая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Activity Mod Plus 1.x (модуль к phpBB)
Уязвимые версии: Activity Mod Plus (модуль для phpBB)

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpbb_root_path" в сценариях "language/lang_english/lang_activity.php" и "lang_activity_char.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://[victim]/[phpBB]/language/lang_english/lang_activity.php?phpbb_root_path=[FILE]

URL производителя: www.phpbb-amod.com

Решение: Установите исправление с сайта производителя.

Ссылки: phpBB 2.x (Activity MOD Plus) File Inclusion Vulnerability

или введите имя

CAPTCHA