PHP-инклюдинг в WordPress

Дата публикации:
31.05.2006
Дата изменения:
24.03.2009
Всего просмотров:
1906
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2667
CVE-2006-2702
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress 2.x
Уязвимые версии: WordPress 2.0.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в различных полях (при регистрации или редактировании профиля пользователя) сохраняемых в директориях wp-content/cache/userlogins/ и wp-content/cache/users/. Удаленный пользователь может с помощью специально сформированного запроса сохранить и выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

Удаленный пользователь может подменить свой IP адрес во время регистрации с помощью HTTP заголовка "PC_REMOTE_ADDR".

URL производителя: wordpress.org

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA