Межсайтовый скриптинг и PHP-инклюдинг в DSChat

Дата публикации:
30.05.2006
Дата изменения:
30.05.2006
Всего просмотров:
1622
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2592
CVE-2006-2605
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DSChat 1.x
Уязвимые версии: DSChat 1.0, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "ctext" в сценарии send.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в поле "Nickname" при создании файла в каталоге "users". Удаленный пользователь может создать и выполнить произвольный PHP файл на системе.

URL производителя: http://www.dvondrake.com/products.php?...ucat=12&

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: DSChat <= 1.0 XSS

или введите имя

CAPTCHA