Переполнение буфера в PunkBuster

Дата публикации:
30.05.2006
Всего просмотров:
920
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PunkBuster 1.x
Уязвимые версии: PunkBuster версии до 1.229

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в административном Web интерфейсе (WebTool) при обработке URL параметра "webkey". Удаленный пользователь может с помощью специально сформированного HTTP запроса, содержащего слишком длинное значение параметра "webkey", вызвать переполнение буфера и выполнить произвольный код на целевой системе.

Для удачной эксплуатации WebTool должен быть включен с помощью свойства "pb_sv_httpPort".

URL производителя: www.punkbuster.com

Решение: Установите последнюю версию (1.229 или выше) с сайта производителя.

Ссылки: Buffer-overflow in the WebTool service of PunkBuster for servers (minor than v1.229)

или введите имя

CAPTCHA