Межсайтовый скриптинг и SQL-инъекция в DGBook

Дата публикации:
29.05.2006
Всего просмотров:
1018
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2572
CVE-2006-2573
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DGBook 1.x
Уязвимые версии: DGBook 1.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "name", "email", "homepage", "address", "comment" и "ip" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения. Удачная эксплуатация уязвимости возможна при выключенной опции "magic_quotes_gpc".

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "name", "homepage", "email" и "address" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.diangemilang.com/dgscripts.php

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: DGbook v1.0 - XSS

или введите имя

CAPTCHA