PHP-инклюдинг в UBB.threads

Дата публикации:
25.05.2006
Всего просмотров:
86475
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
UBB.threads 6.x
Уязвимые версии: UBB.threads 6.4 по 6.5.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "thispath" в сценарии addpost_newpoll.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://[host]/addpost_newpoll.php?addpoll=preview&thispath=[file]

URL производителя: www.ubbcentral.com/ubbthreads/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: UBB.threads >= 6.4.x Remote File Inclusion

или введите имя

CAPTCHA