Переполнение буфера в OpenLDAP

Дата публикации:
22.05.2006
Всего просмотров:
1888
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenLDAP 2.1.x
OpenLDAP 2.2.x
OpenLDAP 2.3.x
Уязвимые версии: OpenLDAP 2.3.21, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки проверки границ данных в slurpd при обработке имени хоста в статус-файле. Удаленный пользователь может с помощью слишком длинного имени хоста вызвать переполнение стека и аварийно завершить работу приложения.

URL производителя: www.openldap.org

Решение: Установите последнюю версию (2.3.22) с сайта производителя.

или введите имя

CAPTCHA