Обход ограничений безопасности в FCKeditor

Дата публикации:
22.05.2006
Дата изменения:
16.04.2007
Всего просмотров:
1487
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие системных данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FCKeditor 2.x
Уязвимые версии: FCKeditor 2.2, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности, получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки при обработке загружаемых файлов. Удаленный пользователь может загрузить произвольный сценарий, указав некорректное значение параметра "Type" в сценарии "editor/filemanager/upload/php/upload.php". Для успешной эксплуатации уязвимости загрузка файлов должна быть включена в файле "config.php".

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "CurrentFolder" в сценарии "connector.php". Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

3. Уязвимость существует из-за ошибки при обработке загрузки файлов. Удаленный пользователь может добавить точку к имени файла и загрузить произвольный сценарий на систему посредством файла "connector.php".

URL производителя: www.fckeditor.net

Решение: Установите последнюю версию (2.3 Beta) с сайта производителя.

Ссылки: Serendipity 1.0-beta3 released

или введите имя

CAPTCHA