PHP-инклюдинг и межсайтовый скриптинг в NewsPortal

Дата публикации:
22.05.2006
Дата изменения:
17.10.2006
Всего просмотров:
1183
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NewsPortal 0.x
Уязвимые версии: NewsPortal версии до 0.37.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в сценарии extras/poll/poll.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Подробное описание уязвимости:

PHP-инклюдинг в TR Newsportal

2. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: florian-amrhein.de/newsportal

Решение: Установите последнюю версию (0.37) с сайта производителя.

или введите имя

CAPTCHA