Переполнение буфера в FreeSSHd

Дата публикации:
16.05.2006
Дата изменения:
27.10.2008
Всего просмотров:
2159
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
freeSSHd 1.x
Уязвимые версии: FreeSSHd 1.0.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке строки алгоритма для обмена ключом, полученным от SSH клиента. Удаленный пользователь может вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: freesshd.com

Решение: Установите последнюю версию 1.0.10 с сайта производителя.

или введите имя

CAPTCHA