Межсайтовый скриптинг и SQL-инъекция в AliPAGER

Дата публикации:
16.05.2006
Всего просмотров:
1591
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2350
CVE-2006-2344
CVE-2006-2345
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
AliPAGER 1.x
Уязвимые версии: AliPAGER 1.5, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "ubild" сценария inc/elementz.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения. Удачная эксплуатация уязвимости возможна при выключенной опции "magic_quotes_gpc".

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "ubild" в сценарии inc/elementz.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.roostercode.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA