Переполнение буфера при обработке ZIP файлов в TZipBuilder

Дата публикации:
15.05.2006
Всего просмотров:
971
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2161
CVE-2006-2993
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
TZipBuilder 1.x
Уязвимые версии: TZipBuilder 1.79.03.01, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при просмотре содержимого ZIP архива. Удаленный пользователь может с помощью специально сформированного ZIP архива, содержащего файл с слишком длинным именем, вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.drehoeksw.net/EZipBuilder.html

Решение: Установите последнюю версию (1.79.04.00) с сайта производителя.

Ссылки: TZipBuilder ZIP File Handling Buffer Overflow Vulnerability

или введите имя

CAPTCHA