Межсайтовый скриптинг в phpkb Knowledge Base

Дата публикации:
04.05.2006
Дата изменения:
24.03.2009
Всего просмотров:
1876
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpkb Knowledge Base 1.x
Уязвимые версии: phpkb Knowledge Base 1.x

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "searchkeyword" в сценарии search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://www.knowledgebase-script.com/demo/search.php?searchkeyword=[XSS]

URL производителя: www.knowledgebase-script.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: PHPKB Knowledge Base - XSS

или введите имя

CAPTCHA