Межсайтовый скриптинг в Pinnacle Cart

Дата публикации:
03.05.2006
Дата изменения:
24.03.2009
Всего просмотров:
1207
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Pinnacle Cart 3.x
Уязвимые версии: Pinnacle Cart

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "setbackurl" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

/index.php?p=&address_id=&setbackurl=[XSS]

URL производителя: www.pinnaclecart.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Pinnacle Cart XSS

или введите имя

CAPTCHA