Переполнение буфера в CGI:IRC

Дата публикации:
03.05.2006
Дата изменения:
03.05.2006
Всего просмотров:
1387
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CGI:IRC 0.x
Уязвимые версии: CGI:IRC 0.5.7, и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в значениях куки в файле client.c. Удаленный пользователь может вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: cgiirc.sourceforge.net

Решение: Установите последнюю версию (0.5.8) с сайта производителя.

или введите имя

CAPTCHA