Межсайтовый скриптинг и SQL-инъекция в HB-NS

Дата публикации:
02.05.2006
Дата изменения:
16.10.2006
Всего просмотров:
1563
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2145
CVE-2006-2146
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
HB-NS 1.x
Уязвимые версии: HB-NS 1.1.6, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "topic" и "id" сценария index.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения. Удачная эксплуатация уязвимости возможна при выключенной опции "magic_quotes_gpc".

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "poster_name", "poster_email", "poster_homepage" и "message". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.haroldbakker.com/php/newsscript.php

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA