Переполнение буфера в Servant Salamander

Дата публикации:
29.04.2006
Дата изменения:
17.10.2006
Всего просмотров:
1194
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Altap Salamander 2.x
Уязвимые версии: Servant Salamander 2.0 и 2.5 beta 11, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в UNACEV2.DLL при обработке ACE архивов, содержащих файл с слишком длинным именем. Удаленный пользователь может с помощью специально сформированного ACE архива вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.altap.cz/salam_en/index.html

Решение: Установите последнюю версию (2.5 RC 1) с сайта производителя.

Ссылки: Secunia Research: Servant Salamander unacev2.dll Buffer OverflowVulnerability

или введите имя

CAPTCHA