SQL-инъекция в photokorn

Дата публикации:
28.04.2006
Дата изменения:
24.03.2009
Всего просмотров:
1289
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2040
CVE-2008-0614
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
photokorn 1.x
Уязвимые версии: photokorn 1.53 и 1.542, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в различных праметрах. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/index.php?action=showgal&cat=[code]
http://[host]/index.php?action=showpic&cat=1&pic=[code]
http://[host]/postcard.php?action=view&id=[code]
http://[host]/index.php?action=showgal&cat=5&page=[code]
http://[host]/print.php?cat=[code]

URL производителя: www.telekorn.com/cms/front_content.php

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: photokorn 1.53 , 1.542 << Sql

или введите имя

CAPTCHA