Выполнение произвольного кода и отказ в обслуживании в PHP

Дата публикации:
25.04.2006
Дата изменения:
17.10.2006
Всего просмотров:
4499
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1990
CVE-2006-1991
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.3.x
PHP 5.0.x
PHP 4.4.x
PHP 5.1.x
Уязвимые версии:
PHP 4.4.2
PHP 5.1.2

Описание:
Удаленный пользователь может вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Переполнение буфера обнаружено в функциях wordwrap(),array_fill() и substr_compare(). Удаленный пользователь, контролирующий входные параметры функций, может вызвать отказ в обслуживании или выполнить произвольный код на целевой системе. Примеры:

$a = str_repeat ("A",438013);
$b = str_repeat ("B",951140);
wordwrap ($a,0,$b,0);
?>

 

URL производителя: www.php.net

Решение: Установите последнюю версию (5.1.3) с сайта производителя.

Ссылки: Multiple PHP4/PHP5 vulnerabilities

или введите имя

CAPTCHA