SQL-инъекция и межсайтовый скриптинг в xFlow

Дата публикации:
21.04.2006
Всего просмотров:
976
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1849
CVE-2006-1850
CVE-2006-1851
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
xFlow 5.x
Уязвимые версии: xFlow 5.46.11, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "position" и "id" в сценарии members_only/index.cgi. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "level", "position", "id" и "action" в сценарии members_only/index.cgi, и в параметре "page" в сценарии customer_area/index.cgi. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.skymarx.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: xFlow v5.x multiple vuln.

или введите имя

CAPTCHA