Множественные уязвимости в RechnungsZentrale V2

Дата публикации:
21.04.2006
Дата изменения:
24.03.2009
Всего просмотров:
992
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1954
CVE-2006-1955
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
RechnungsZentrale V2
Уязвимые версии: RechnungsZentrale V2 1.1.3, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести SQL-инъекцию и выполнить произвольный PHP сценарий на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "user" в сценарии mod/authent.php4. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "rootpath" сценария mod/authent.php4. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена, и опция "magic_quotes_gpc" должны быть отключена.

URL производителя: www.nfec.de/index.php?option=com_content&task=view&id=18&Itemid=40

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: SQL Injection and Remote File inclusion Vulnerabilities in RechnungsZentrale v2

или введите имя

CAPTCHA