Межсайтовый скриптинг в BannerFarm

Дата публикации:
21.04.2006
Всего просмотров:
821
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
BannerFarm 2.x
Уязвимые версии: BannerFarm 2.3, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "aff" и "cat" в сценарии banners.cgi. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

/banners.cgi?aff=[XSS]
/banners.cgi?aff=&cat=[XSS]

URL производителя: www.perlcoders.com/main/scripts.html?script=BannerFarm

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: BannerFarm XSS vuln.

или введите имя

CAPTCHA