Обход ограничений безопасности в ядре Linux

Дата публикации:
20.04.2006
Всего просмотров:
2385
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1524
CVE-2006-2071
Вектор эксплуатации:
Локальная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Kernel 2.6.x
Уязвимые версии: Linux kernel версии до 2.6.16.7

Описание:
Уязвимость позволяет локальному пользователю обойти ограничения безопасности.

Уязвимость существует из-за того, что функция "mprotect()" устанавливает привилегии на запись для доступных только на чтение вложений разделяемой памяти, не зависимо от установленных привилегий IPC.

URL производителя: kernel.org

Решение: Установите последнюю версию ядра с сайта производителя.

Ссылки: shmat: stop mprotect from giving write permission to a readonly attachment (CVE-2006-1524)

или введите имя

CAPTCHA