Межсайтовый скриптинг в Calendarix

Дата публикации:
19.04.2006
Дата изменения:
28.02.2009
Всего просмотров:
873
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Calendarix Basic 0.x
Calendarix Advanced 1.x
Уязвимые версии:
Calendarix Basic 0.x
Calendarix Advanced 1.x

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "ycyear" в сценарии yearcal.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://victim/[path]/yearcal.php?ycyear=<script>alert(document.cookie)</script>

URL производителя: www.calendarix.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Calendarix "yearcal.php" XSS Attacking

или введите имя

CAPTCHA