Переполнение буфера в Amaya

Дата публикации:
18.04.2006
Дата изменения:
30.12.2008
Всего просмотров:
952
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Amaya 9.x
Уязвимые версии: Amaya 9.4 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке значений различных атрибутов. Удаленный пользователь может вызвать переполнение стека во время открытия специально сформированного HTML документа, содержащего определенные теги с очень длинными значениями атрибутов, и выполнить произвольный код на целевой системе.

URL производителя: www.w3.org/Amaya/

Решение: Установите последнюю версию (9.5) с сайта производителя.

Ссылки: [BuHa-Security] Stack Based Buffer Overflow Vulnerability in Amaya 9.4
[BuHa-Security] Stack Based Buffer Overflow Vulnerability in Amaya 9.4 #2

или введите имя

CAPTCHA