PHP-инклюдинг в PAJAX

Дата публикации:
17.04.2006
Дата изменения:
17.10.2006
Всего просмотров:
1716
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1551
CVE-2006-1789
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PAJAX 0.x
Уязвимые версии: PAJAX 0.5.1 и более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный PHP код на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "method" и "args" в сценарии pajax_call_dispatcher.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

2. Уязвимость существует из-за недостаточной обработки входных данных в переменной "className". Удаленный пользователь может с помощью символов обхода каталога подключить произвольные .class.php файлы на ситеме.

URL производителя: www.auberger.com/pajax/

Решение: Установите последнюю версию 5.0.2 с сайта производителя.

Ссылки: PAJAX Remote Code Injection and File Inclusion Vulnerability

или введите имя

CAPTCHA