Множественные уязвимости в apt-webshop-system

Дата публикации:
11.04.2006
Дата изменения:
17.10.2006
Всего просмотров:
1345
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1685
CVE-2006-1687
CVE-2006-1686
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
apt-webshop-system 4.x
apt-webshop-system 3.x
Уязвимые версии: apt-webshop-system 3.0 light, 3.0 basic, и 4.0 pro

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "id" сценария modules.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения. Пример:

/modules.php?warp=artikel&group=[SQL]
/modules.php?warp=artikel&group=&seite=[SQL]
/modules.php?warp=artikel&group=&seite=&id=[SQL]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "message". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.apt-webservice.de/shopsoftware/modules.htm

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: APT-webshop-system vuln.

или введите имя

CAPTCHA