Межсайтовый скриптинг в Cherokee Web Server

Дата публикации:
11.04.2006
Всего просмотров:
1213
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Cherokee 0.x
Уязвимые версии: Cherokee 0.5.0, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных HTTP запросах в функции "build_hardcoded_response_page()" файла cherokee/handler_error.c. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/..[code]

URL производителя: www.alobbs.com/cherokee/

Решение: Установите последнюю версию (0.5.1) с сайта производителя.

или введите имя

CAPTCHA