Межсайтовый скриптинг в Andy's PHP Knowledgebase

Дата публикации:
11.04.2006
Дата изменения:
24.03.2009
Всего просмотров:
997
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Andy's PHP Knowledgebase 0.x
Уязвимые версии: Andy's PHP Knowledgebase 0.57, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "keyword_list" сценария "abk.php" и различных параметрах в сценариях submit_article.php" и "submit_question.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: aphpkb.sourceforge.net

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA