Выполнение произвольного кода в OpenVPN

Дата публикации:
11.04.2006
Дата изменения:
29.12.2008
Всего просмотров:
1452
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenVPN 2.x
Уязвимые версии: OpenVPN 2.0 - 2.0.5

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из—за того, что OpenVPN клиент позволяет серверу передать клиентскому сценарию переменные окружения, включая LD_PRELOAD посредством конфигурационных директив "setenv". Удаленный пользователь может выполнить произвольный код на системе клиента, поместив злонамеренный файл в определенный каталог и загрузив его. Для удачной эксплуатации уязвимости пользователь должен подключиться к злонамеренному серверу.

URL производителя: openvpn.net

Решение: Установите последнюю версию (2.0.6) с сайта производителя.

Ссылки: Virtual Private Networks Made Easy
http://openvpn.net/changelog.html
http://www.osreviews.net/reviews/security/openvpn-print

или введите имя

CAPTCHA