Множественные уязвимости в Interact

Дата публикации:
10.04.2006
Дата изменения:
31.10.2008
Всего просмотров:
1182
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1642
CVE-2006-1643
CVE-2006-1644
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Interact 2.x
Уязвимые версии: Interact 2.1.1 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение, выполнить произвольные SQL команды в базе данных приложения и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "user_name" сценария login.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "search_terms" в сценарии search.php и в различных полях при создании учетной записи. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

3. Сценарий "login.php" возвращает различные ответы при неудачной попытке авторизации, в зависимости от того, было ли указано корректное имя пользователя. Удаленный пользователь может получить список валидных пользователей приложения.

URL производителя: www.interactlms.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA