Переполнение буфера в Kaffeine Player

Дата публикации:
10.04.2006
Всего просмотров:
1353
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Kaffeine Player 0.x
Уязвимые версии: Kaffeine Player 0.4.2 - 0.7.1

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "http_peek()" во время создания заголовков HTTP запроса для получения удаленного списка произведений. Удаленный пользователь может с помощью специально сформированного плейлиста вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: sourceforge.net/projects/kaffeine/

Решение: Установите последнюю версию (0.8.0) с сайта производителя.

Ссылки: KDE Security Advisory: Kaffeine buffer overflow

или введите имя

CAPTCHA