Межсайтовый скриптинг в gtd-php

Дата публикации:
07.04.2006
Дата изменения:
24.03.2009
Всего просмотров:
1445
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
gtd-php 0.x
Уязвимые версии: gtd-php 0.5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в различных полях в сценариях newProject.php, newList.php, newWaitingOn.php, newChecklist.php, newContext.php, newCategory.php и newGoal.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "listTitle" в сценарии listReport.php, параметре "projectName" в сценарии projectReport.php, и параметре "checklistTitle" в сценарии checklistReport.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: gtd-php.sourceforge.net

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA