Выполнение произвольных команд в Horde Help Viewer

Дата публикации:
07.04.2006
Дата изменения:
13.02.2009
Всего просмотров:
1371
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Horde Application Framework 3.x
Уязвимые версии: Horde Application Framework версии до 3.0.10 и 3.1.1

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "module" в сценарии "services/help/" перед вызовом функции "eval()". Удаленный пользователь может с помощью специально сформированного запроса к Horde Help Viewer выполнить произвольный PHP код на целевой системе с привилегиями Web сервера.

URL производителя: www.horde.org/horde/

Решение: Установите последнюю версию 3.0.10 или 3.1.1 с сайта производителя.

Журнал изменений:

13.02.2009
Изменено описание уязвимости.

Ссылки: Horde 3.1.1 (final)
Horde 3.0.10 (final)

или введите имя

CAPTCHA