Переполнение буфера в Zdaemon

Дата публикации:
07.04.2006
Всего просмотров:
923
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1592
CVE-2006-1593
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ZDaemon 1.x
Уязвимые версии: Zdaemon 1.08.01, возможно другие версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных в клиентских картах (“(wad” файлы) во время подключения клиента к серверу. Удаленный пользователь может с помощью специально сформированного имени карты, содержащего более 256 символов, вызвать переполнение буфера и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за некорректного обращения к памяти в функциях "ZD_MissingPlayer()", "ZD_UseItem()" и "ZD_ValidClient()". Удаленный пользователь может аварийно завершить работу сервера.

URL производителя: www.zdaemon.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Zdaemon Denial of Service and Buffer Overflow Vulnerabilities

или введите имя

CAPTCHA