Межсайтовый скриптинг в Mantis

Дата публикации:
06.04.2006
Дата изменения:
24.03.2009
Всего просмотров:
967
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MantisBT 0.x
MantisBT 1.x
Уязвимые версии: Mantis 1.0.1, 1.0.0rc5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в праметрах "start_day", "start_year" и "start_month" в сценарии "view_all_set.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/view_all_set.php?type=1&temporary=y&do_filter_by_date=on&start_year=2006&start_month=03&start_day=[code]
http://[host]/view_all_set.php?type=1&temporary=y&do_filter_by_dateon&start_year=[code]
http://[host]/view_all_set.php?type=1&temporary=y&do_filter_by_date=on&start_year=2006&start_month=[code]

URL производителя: www.mantisbt.org

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Mantis XSS vuln.

или введите имя

CAPTCHA