Межсайтовый скриптинг в phpPgAds / phpAdsNew

Дата публикации:
03.04.2006
Дата изменения:
09.02.2009
Всего просмотров:
2787
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenX (ранее Openads и phpAdsNew) 2.x
Openads for PostgreSQL (ранее phpPgAds) 2.x
Уязвимые версии:
phpAdsNew 2.0.7 и более ранние версии
phpPgAds 2.0.7 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в сценарии, обрабатывающем баннеры. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в полях формы аутентификации. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.phppgads.com

Решение: Установите последнюю версию (2.0.8) с сайта производителя.

Ссылки: phpAdsNew and phpPgAds 2.0.8 released

или введите имя

CAPTCHA