Раскрытие данных в функции "html_entity_decode()" в PHP

Дата публикации:
29.03.2006
Дата изменения:
17.10.2006
Всего просмотров:
2799
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.3.x
PHP 5.0.x
PHP 4.4.x
PHP 5.1.x
Уязвимые версии:
PHP 4.4.2 и более ранние версии
PHP 5.1.2 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным на системе.

Уязвимость существует из-за ошибки в функции "html_entity_decode()". Удаленный пользователь может получить доступ к определенным участкам памяти на системе с помощью сценария, вызывающего функцию "html_entity_decode()". Удачная эксплуатация уязвимости возможна, если злоумышленник может контролировать входные данные и получить результат выполнения функции.

URL производителя: php.net

Решение: Уязвимость исправлена в версии 5.1.3-RC1, доступной по CVS.

Ссылки: Critical PHP bug - act ASAP if you are running web with sensitive data

или введите имя

CAPTCHA