Множественные уязвимости в PHP iCalendar

Дата публикации:
27.03.2006
Всего просмотров:
1130
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-1291
CVE-2006-1292
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP iCalendar 2.x
Уязвимые версии: PHP iCalendar 2.21, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю загрузить и выполнить произвольный PHP сценарий на системе и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "cookie_language" и "cookie_style" в файле куки. Удаленный пользователь может с помощью специально сформированного файла куки просмотреть произвольные файлы на системе.

2. Уязвимость существует из-за отсутствия необходимых привилегий на доступ к директории upload. Удаленный пользователь может послать специально сформированный PUT запрос к сценарию publish.ical.php, содержащий имя файла с NULL символом в параметре "X-WR-CALNAME", загрузить и выполнить произвольный PHP файл на целевой системе с привилегиями Web сервера.

URL производителя: phpicalendar.net

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA